2020 RV-Dreams Spring Educational Rally - April 20 - 26, 2020 - Sevierville/Pigeon Forge, Tennessee - REGISTRATION IS NOW OPEN!!

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Why is my RV showing 50 amps when I'm hooked up to 30?


RV-Dreams Family Member

Status: Offline
Posts: 26
Date:
Why is my RV showing 50 amps when I'm hooked up to 30?


Hello folks and thank you so much in advance for any advice you can offer!

We've been full-timing for a little over a month now, in a Winnebago Sightseer.  This is our very first RV experience and, so far, we'd only been staying at 50 Amp sites.  Now we've checked into a new RV park and I thought I'd save us some money by choosing a 30 Amp site.  We pulled in a couple days ago and noticed right away that the 'Powerline Energy Management System' showed that we had 30 Amp service, and displayed the number of Amps we were using at any given time.  Today however, I noticed that the display now indicates 50 Amp.  What's up with that?  We consulted with the RV park owner who confirmed (of course) that we were on a 30 Amp hookup - which we knew to be true because we were using the 30 Amp plug, and the breaker switch is listed as 30 Amps.

So how come our power management system thinks we're at 50 Amps?  And are we endangering the power system?

Thank you so much for any advice!  I looked through the forums but didn't see another topic that addressed this.

Melnal (so incredibly new to RV'ing that we are more than likely to ask stupid questions wink)



__________________

Mel (the Mel in Melnal, and author of http://wheresphoebe.com)



RV-Dreams Family Member

Status: Offline
Posts: 26
Date:

I think I posted this in the wrong place.  Looking for a better folder :)



__________________

Mel (the Mel in Melnal, and author of http://wheresphoebe.com)

Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us