2019 RV-Dreams Spring Educational Rally - April 8 - 14, 2019 - Pahrump, Nevada - Registration is now open!!

Members Login
Username 
 
Password 
    Remember Me  
Post Info TOPIC: Hot Water Heater and DSI Fault


RV-Dreams Family Member

Status: Offline
Posts: 5202
Date:
Hot Water Heater and DSI Fault


I learned something new today over on another forum.  A participant there asked the question about something between the switches for electric and gas with regards to the hot water heater.  He had seen the letters "DSI" with a red indicator light between that and the letters "FLT."  So, I went to look at ours and we have similar but instead of "FLT," ours had the word "fault."

So, with the opportunity to learn something new, I went and used my "Bing-fu" skills to find out.  DSI stands for "Direct Spark Ignitor."  I also found an explanation of the DSI Fault at another forum.  A participant there gave this description:

 

"OK that means your hot water heater failed to start. It tried 3 times and locked out. Direct Spark Ignitor fault (flt). You probably have air in the line and it needs to be flushed out. I usually just run my stove top on 3 burners for a minute to bleed the air out.  Just turn the hot water heater off for a minute or so and it should try again 3 more times till it lights. If not its gas side is broke. Electric side should still work."

 

So, since I learned something new, I thought I'd pass that same information off to others, some of whom haven't even RV'ed yet.

Terry



__________________

Terry and Jo

2010 Mobile Suites 38TKSB3
2008 Ford F450
2017 Ford Expedition EL as Tag-along or Scout

Our photos on Smugmug



RV-Dreams Family Member

Status: Offline
Posts: 40
Date:

I'm having some issues with my six gallon DSI gas only Atwood water heater.  I searched "DSI FLT" and was rewarded with Terry's post from a few years ago and thought this would be good place to post my question.

When I first turn on my water heater from the monitor panel, it fires up right away and heats the water to what I assume is the proper temperature then shuts down.  (When I get a moment I'll get a thermometer and check the temperature)  But as hot water is used, or the temperature just drifts down, the heater does not come back on but I see the DSI FLT (fault) LED come on.  If I turn off the water heater switch at the monitor panel then turn it back on, the water heater fires back up, heats the water but will not cycle back on when needed.  The manual says this indicates a problem with the igniter but the igniter never fails to ignite when I first turn on the water heater or when I switch it off then back on. 

This RV is just over a year old and I first noticed this problem about a month ago.

Has anyone experienced this or have a suggestion on what to check?

Thanks,

Steve



__________________

2017 Starcraft 26BHS Autumn Ridge TT,  2004 Toyota Tundra TV 

Plan to retire/full-time in 2021. Favorite place to camp; Texas State Parks.

Travel is fatal to prejudice, bigotry, and narrow-mindedness..  Mark Twain 

Steve, Julie and Ethan

ENG


RV-Dreams Community Member

Status: Offline
Posts: 1
Date:

I had a simular problem with mine. In my case I have a Jensen control panel and had to update the software. Solved the problem

__________________
Page 1 of 1  sorted by
 
Quick Reply

Please log in to post quick replies.

Tweet this page Post to Digg Post to Del.icio.us